2018年05月09日

引き続き悪戦苦闘!NP2! 3

ビルドとーったー!やっとビルド通った。
まだ、Android4.4だけど・・・

続きはまた今度やろう。
明日もお仕事だ。

因みに、以下の環境でビルド通りました。
AndroidStudio 2.2.2(探してDLしたw)
JAVA 1.8.0_51
NDK android-ndk-r8e

で、APKビルドまで出来て、Android4.4環境で「ピポっ!」と鳴ったw

さーて、これから、Android7に対応すべき頑張ろう。

posted by Norihide at 00:50 | Comment(6) | TrackBack(0) | GPD XD Plus
この記事へのコメント
おめでとうございます!!
android studio2.2.2でないとダメですね
最新バージョンとの違いはなんだろう…
Posted by きら at 2018年05月09日 06:26
きらさん

ありがとうございます!!
最新でも、もしかしたらイケるかも?しれません・・・

JAVAを一回全部消して、やり直したのが大きいのかも。

あとは大きな壁、NDKですねー・・・
NDK上げると、Cソースでエラーになるのでどうしたものかと・・・

Posted by Norihide at 2018年05月09日 22:31
こんにちは
のりひでさんのアドバイスどおり
元ソースをダウンロード。
android.mk指定をやり直してビルドが通りました!
ありがとうございます(^-^)
ただ、apkをインストールし立ち上げると強制終了(T_T)

android studio 3.1.2
jdk 1.8.0_171
ndk r8e

apiは13(android3.2)と22(android5.1)
を試しましたがいずれも強制終了です。
android studio2.2.2とjdk1.8.0_51じゃないとダメかなー
jdk1.8.0_51の直リンク貼って頂けませんか?




Posted by きら at 2018年05月19日 15:50
きらさん

おそらく原因は、android studioのせいじゃないですかね。
僕もandroid studio3だと同じ現象になりました。
Posted by Norihide at 2018年05月20日 13:09
こんにちは
ダウンロード完了です!ありがとうございました(^_^)
しかしandroid studioは気難しくて困る(T_T)
早速試してみますね!
Posted by きら at 2018年05月20日 17:39
きらさん

了解です!

でも、本当にAndroid studio難しくて困る・・・

なんかGRIDってのがややこしい原因のような気がします。
Posted by Norihide at 2018年05月20日 19:51
コメントを書く
お名前: [必須入力]

メールアドレス:

ホームページアドレス:

コメント: [必須入力]

※ブログオーナーが承認したコメントのみ表示されます。
この記事へのトラックバックURL
http://blog.sakura.ne.jp/tb/183185390
※ブログオーナーが承認したトラックバックのみ表示されます。

この記事へのトラックバック